Задать вопрос
3 января, 16:03

Нужно составить программу в paskal ABC:

Массив содержит n случайных двузначных чисел. Определить сколько в данном массиве четных чисел. Вывести все его элементы с нечетными номерами.

+5
Ответы (2)
  1. 3 января, 18:18
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, k:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (90) + 10;

    write (a[i]:4) ;

    end;

    writeln;

    k:=0;

    for i:=1 to n do

    if a[i] mod 2=0 then k:=k+1;

    writeln ('Четных чисел: ', k) ;

    writeln ('Элементы с нечетными номерами:') ;

    for i:=1 to n do

    if i mod 2=1 then write (a[i]:4) ;

    writeln;

    end.

    Пример:

    Массив A:

    13 77 63 94 75 87 22 56 59 42

    Четных чисел: 4

    Элементы с нечетными номерами:

    13 63 75 22 59
  2. 3 января, 19:06
    0
    Var a: array [1 ... 10] of integer; var kolvo:integer; beginfor var i: = 1 to 10 do a[i]: = random (89) + 10; for var c: = 1 to 10 do begin if (a[c] mod 2 = 0) then kolvo:=kolvo+1; end; writeln ('Четных чисел: ', kolvo) ; for var i: = 1 to 10 do write (a[i]:4) ; end. объяснение нужно?
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно составить программу в paskal ABC: Массив содержит n случайных двузначных чисел. Определить сколько в данном массиве четных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите решение задачи через паскаль. 1. Массив из 10 целых чисел из промежутка [10,20] задается с помощью гениратора случайных чисел. Вывести полученный массив в строку. Затем увеличить каждый элемент на 5.
Ответы (1)