Задать вопрос
31 августа, 09:52

Написать программу, которая генерирует 10 четных чисел и сортирует их по возрастанию.

Точного промежутка чисел в условии нет, но я думаю, можно поставить свое - например, 100

+4
Ответы (1)
  1. 31 августа, 12:11
    0
    Type

    arr = array[1 ... 10] of integer;

    const / / числа, которые генерируются (от 0 до d-1)

    d = 101;

    var / / массив, хранящий сгенерированные числа

    a: arr;

    procedure Sort (var arg: arr) ; / / сортирует массив по возрастанию

    var

    t: integer;

    begin

    for var i : = 1 to 9 do

    for var j : = 1 to 9 do

    if arg[j] > arg[j + 1] then begin

    t : = arg[j];

    arg[j] : = arg[j + 1];

    arg[j + 1] : = t;

    end;

    end;

    begin

    randomize () ;

    for var i : = 1 to 10 do a[i] : = Random (d) ; / / генерация рандомных чисел (0 ... d-1)

    Sort (a) ; / / сортировка массива

    for var i : = 1 to 10 do write (a[i], ' ') ; / / вывод массива

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая генерирует 10 четных чисел и сортирует их по возрастанию. Точного промежутка чисел в условии нет, но я думаю, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio)
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)
Антон сортирует по возрастанию список из 10 элементов: 6 12 3 4 9 2 10 11 7 5 Ему разрешается поменять местами любые два элемента, но за такой обмен ему придется отдать количество конфет, равное разности позиций обмениваемых элементов (позиции
Ответы (1)