Задать вопрос
17 марта, 18:52

Напишите программу для решения задачи. В видеоигре игрок выигрывает 50 очков, если он сбивает самолет, 100 очков, если он сбивает ракету, 200 очков, если он сбивает спутник. Составьте программу, которая выведет на экран число очков игрока, который сбил А самолетов, В ракет и С спутников.

+3
Ответы (1)
  1. 17 марта, 19:49
    0
    Var

    a, b, c, d:Integer;

    begin

    Writeln ('Ведите сколько вы сбили самолётов:') ;

    readln (a) ;

    Writeln ('Ведите сколько вы сбили ракет:') ;

    readln (b) ;

    Writeln ('Ведите сколько вы сбили спутников:') ;

    readln (c) ;

    a:=a*50;

    b:=b*50;

    c:=c*50;

    d:=a+b+c;

    writeln ('У вас ', d, ' очков') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для решения задачи. В видеоигре игрок выигрывает 50 очков, если он сбивает самолет, 100 очков, если он сбивает ракету, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 2 камня, во второй - 3, в третьей - 4. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 3 камня, во второй - 1. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)
Имеется три кучки камней - 2, 3 и 4 камня. Два игрока ходят по очереди. Ход состоит в том, что игрок либо удваивает число камней в какой-то кучке, либо добавляет по 2 камня в каждую из куч.
Ответы (1)
Из-за непогоды были отменены рейсы самолетов. Ненадолго проглянуло солнце: на N часов и M минут. Напишите программу, которая определяет, сколько самолетов успеет вылететь за это время, если на взлетной полосе может быть только один самолет, а
Ответы (1)
1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу два камня или увеличить количество камней в куче в два раза.
Ответы (1)