Задать вопрос
5 октября, 15:26

Написать программу по информатике Z=sqrt|d^3-2|+3t Данные : dN = - 2 dK=1 Hd=0.5 tN=-1 tK = - 3 Ht = - 1

+5
Ответы (1)
  1. 5 октября, 17:11
    0
    Const dN=-2; dK=1; Hd=0.5; tN=-1; tK=-3; Ht=-1;

    var d, t, z:real; i, j, n1, n2:integer;

    begin

    n1:=round ((dK-dN) / Hd) ;

    n2:=round ((tK-tN) / Ht) ;

    d:=dN-Hd;

    writeln (' d t z') ;

    for i:=0 to n1 do

    begin

    d:=d+Hd;

    t:=tN-Ht;

    for j:=0 to n2 do

    begin

    t:=t+Ht;

    z:=sqrt (abs (d*d*d-2)) + 3*t;

    writeln (d:4:1,' ', t:4:1,' ', z:6:3) ;

    end;

    end;

    end.

    Результат:

    d t z

    -2.0 - 1.0 0.162

    -2.0 - 2.0 - 2.838

    -2.0 - 3.0 - 5.838

    -1.5 - 1.0 - 0.682

    -1.5 - 2.0 - 3.682

    -1.5 - 3.0 - 6.682

    -1.0 - 1.0 - 1.268

    -1.0 - 2.0 - 4.268

    -1.0 - 3.0 - 7.268

    -0.5 - 1.0 - 1.542

    -0.5 - 2.0 - 4.542

    -0.5 - 3.0 - 7.542

    0.0 - 1.0 - 1.586

    0.0 - 2.0 - 4.586

    0.0 - 3.0 - 7.586

    0.5 - 1.0 - 1.631

    0.5 - 2.0 - 4.631

    0.5 - 3.0 - 7.631

    1.0 - 1.0 - 2.000

    1.0 - 2.0 - 5.000

    1.0 - 3.0 - 8.000
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу по информатике Z=sqrt|d^3-2|+3t Данные : dN = - 2 dK=1 Hd=0.5 tN=-1 tK = - 3 Ht = - 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Записать в виде обычной математической формулы 1) y:=2*sin (x) * sqrt (x+sqrt (abs (x))) 2) y: = sqrt (sin (x) + sin (sqrt (x))) 3) y: = sqrt (abs (x-1) + sqrt (sin (x))) 4) y: = (5*sin (x) + 4) / 2*15*sin (sqrt (x)) 5) k+15*x / (2*sin (x)) 6) y:=
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Написать программу построения графика функции у = sqrt 3*x. (PascalABC) (программа не работает) uses graphabc; var i: integer; x, y: real; function f (x:real) : real; begin f:=sqrt (3*x) ; end; Begin line (0, 240, 620, 240) ;
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)