Задать вопрос
4 ноября, 13:19

Даны два угла треугольника (в градусах). Определить, существует ли такой треугольник. Если да, то прямоугольный ли он.

+3
Ответы (2)
  1. 4 ноября, 13:29
    0
    Сума трех углов треугольника - 180°. В прямоугольном один угол 90°, и сумма двух других углов тоже 90°.

    Если даны стороны - (правило неравенства треугольников) бо'льшая сторона всегда больше разности двух других сторон и меньше их суммы. Прямоугольность можно проверить по теореме Пифагора - квадрат гипотенузы (бо'льшей стороны) равен сумме квадратов катетов.
  2. 4 ноября, 14:12
    0
    Var a, b:integer;

    begin

    readln (a, b) ;

    if a+b<180 then

    begin

    write ('Да. ') ;

    if (a=90) or (b=90) or (a+b=90)

    then writeln ('Прямоугольный')

    else writeln ('Не прямоугольный') ;

    end

    else writeln ('Нет') ;

    end.

    Пример:

    30 60

    Да. Прямоугольный
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два угла треугольника (в градусах). Определить, существует ли такой треугольник. Если да, то прямоугольный ли он. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в Pascal. Даны два угла треугольника (в градусах). Определить, существует ли такой треугольник. Если да, то будет ли он прямоугольным.
Ответы (1)
Даны натуральные числа a, b, c. Проверьте существует ли треугольник величины углов, которого в градусах при положительном результате установит вид треугольника: остроугольный, тупоугольный, прямоугольный? это в программе pascal
Ответы (2)
Выходные данные Даны три натуральных числа a, b, c, записанные в отдельных строках. Определите, существует ли треугольник с такими сторонами (использовать неравенство треугольника Выходные данные Если треугольник существует, введите строку yes, если
Ответы (1)
Даны три стороны треугольника. определить существует ли треугольник с заданными сторонами, если да, то определить является ли он прямоугольным, равнобедренным или равносторонним, какой треугольник тупоугольный или остроугольный.
Ответы (1)
Помогите решить (python 3.6) Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)