Задать вопрос
12 августа, 21:49

Требуется найти n-ый член последовательности типа 1121123211234321 Ограничение по времени: 5 сек Ограничение n<10^500 000

+1
Ответы (1)
  1. 13 августа, 01:06
    0
    Uses crt, math;

    var n: extended;

    var x: extended;

    var s: extended;

    var f: extended;

    var t: extended;

    begin

    { вводим значения }

    writeln ('Enter n:') ; readln (n) ;

    if n > 0 then begin

    { номер последовательности }

    x : = ceil ((sqrt (1.0 + 4.0 { 8.0 } * n) - 1.0) / 2.0) ;

    { количество элементов всех последовательностей }

    s : = x + x*x;

    { s : = s / 2; }

    { относительный номер элемента в последовательности }

    f : = x * 2 - (s - n) ;

    if f < = x then begin

    t : = 1 + x - f;

    end;

    if f > x then begin

    t : = f - x;

    end;

    { выводим результат }

    writeln ('t = ', t) ;

    { задержка }

    readln (n) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Требуется найти n-ый член последовательности типа 1121123211234321 Ограничение по времени: 5 сек Ограничение n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Имеется два различных типа носителей информации: носитель типа А - с максимальным объемом записываемой на него информации 30 ГБайт, типа В - 680 МБайт.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Как это решать? И что тут вообще надо сделать? A+B Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны 2 числа a и b. Найти сумму этих чисел.
Ответы (1)
Яблочки Ограничение времени 2 секунды Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt После очередного успеха на олимпиаде Никита и Кирилл решили открыть собственный бизнес.
Ответы (1)
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)