Задать вопрос
22 ноября, 23:25

Program qwerty;

uses crt, graphabc;

var x, y, x0, y0, k:real;

begin

x0:=320; y0:=240;

k:=50;

for x:=-320 to 320 do begin

if x<0 then y:=x*x

else

if (x>=0) and (x<10) then y:=x

else

if x>=10 then y:=1/x

end;

end.

Почему в 7 строчке перед х пишет "ожидался порядковый тип"?

+5
Ответы (1)
  1. 23 ноября, 02:52
    0
    Program qwerty; uses crt, graphabc; var x, x0, y0, k:integer; y:real; beginx0:=320; y0:=240; k:=50; for x: = - 320 to 320 do beginif x=0) and (x=10 then y:=1/xend; end.

    Вы "счетчик" в real объявили, а он должен быть integer
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Program qwerty; uses crt, graphabc; var x, y, x0, y0, k:real; begin x0:=320; y0:=240; k:=50; for x:=-320 to 320 do begin if x=0) and (x=10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Где здесь ошибка? program P12; uses crt; var a, b, c:real; i, n:integer; function F (x:real) : real; begin f:=sqr (sqr (x)) + (sqr (x)) * x-8*x (sqr (x)) + 5*x-3-cos (2*x) ; end; begin clrscr; a:=0; b:=1; n:=20; for i:=1 to n do begin c: = (a+B) / 2;
Ответы (1)
Почему выводится ноль в программе? program pr1; var a: real; n: longint; function power (a:real; n:longint) : real; begin var i: integer; var anew: real; anew:=a; for i: = 2 to n do begin a:=a*anew; end; end; begin readln (a, n) ;
Ответы (1)
Написать программу построения графика функции у = sqrt 3*x. (PascalABC) (программа не работает) uses graphabc; var i: integer; x, y: real; function f (x:real) : real; begin f:=sqrt (3*x) ; end; Begin line (0, 240, 620, 240) ;
Ответы (1)
Выдаёт ошибку: операнды имеют неприводимые типы. Где я ошиблась? (Программа написана на языке Pascal ABC) Program Home; Uses CRT; Var a: integer; b: real; Begin WriteLn ('Введите еденицу измереня: килограмм, миллиграмм, грамм, тонна, центнер') ;
Ответы (1)
надо решать через Паскаль. составил две программы и обе со странным ответом. что не то? program qwe; uses crt; var x. s:integer; y:real; begin s:=0; for i: = - 2 to 27 do s:=s+x; y:=s/30 writeln ('srednee arifmeticheskoe=', y) ; readkey; end.
Ответы (1)