Задать вопрос
1 июня, 19:08

Помогите с информатикой! (нужно оформить задачу в Паскале

Определить количество минимальных чисел случайной последовательности 450 трехзначных чисел

+2
Ответы (1)
  1. 1 июня, 23:07
    0
    const n = 450;

    var

    i, min, s: integer;

    arr:array[1 ... n] of integer;

    begin

    min:=999;

    s:=0;

    for i:=1 to n do begin

    arr[i]:=random (900) + 100;

    if arr[i]<=min then begin

    min:=arr[i];

    end;

    end;

    for i:=1 to n do

    if arr[i]=min then s:=s+1;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с информатикой! (нужно оформить задачу в Паскале Определить количество минимальных чисел случайной последовательности 450 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Предложено описание термина, не связанного с информатикой. Определите этот термин. Удалите из него одну букву так, чтобы получился термин, связанный с информатикой. В ответ запишите только полученное слово в именительном падеже.
Ответы (1)
10 класс Напишите программу в паскале, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO).
Ответы (1)
Дана последовательность целых чисел (не менее 100). Элементы последовательности генерируются случайным образом в диапазоне [-3; 3]. Вывести первый минимум и его номер (в предположении, что в последовательности несколько минимальных элементов).
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)