Задать вопрос
26 июля, 19:50

Составить программу в Паскале и блок схему:

Вычисление суммы ряда S=1-1/2+1/4-1/6 + ... 1/N.

+3
Ответы (1)
  1. 26 июля, 22:40
    0
    Вот держите:

    var n, i, l, m:integer; sum:real;

    begin

    readln (n) ;

    sum:=1; l:=1;

    while mn do begin

    m:=m+2;

    sum:=sum - ((1/m) * l) ;

    l:=l*-1;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскале и блок схему: Вычисление суммы ряда S=1-1/2+1/4-1/6 + ... 1/N. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Y={0, если х≤0 х, если 0
Ответы (1)
1. Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно. 2. Составить блок - схему кипячения чайника. 3. Составить алгоритм сбора яблок в саду.
Ответы (1)
Укажите, что дано и что надо получить: а) вычисление стоимости покупок в магазине б) вычисление суммы сдачи от данных вами продавцу денег в) определение времени показа по телевизору интересующего вас фильма г) вычисление площади треугольника д)
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Составить блок-схему вычисления суммы или произведение числового ряда. Слогаемые (или сомножетели) ряда вывести на экран. Использовать цикл с известным числом повторений: S=sin1+sin1.1+sin1.2 + ... + sin2
Ответы (1)