Задать вопрос
1 июня, 11:39

Сделать в Free Pascal.

В салон красоты пришло n девушек. Каждая из них должна посетить парикмахера и косметолога. У каждого она проводит по m часов. За какое наименьшее время k сотрудников салона красоты смогут обслужить всех девушек, если каждый сотрудник может выполнять функции как косметолога, так и парикмахера?

Входные данные

три натуральных числа k, m, n (все числа не больше 10 000).

Исходные данные

одно число - минимальное время в часах, которое требуется для обслуживания всех девушек.

+5
Ответы (1)
  1. 1 июня, 14:54
    0
    Begin

    write ('n m k через пробел: ') ;

    readln (n, m, k) ;

    s:=2*n*m;

    p:=0;

    repeat

    s:=s-k*2*m;

    p:=p+1;

    until s<=0;

    p:=p*2*m;

    writeln ('время: ', p) ;

    end.

    n m k через пробел: 3 2 5

    время: 4

    n m k через пробел: 6 2 4

    время: 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сделать в Free Pascal. В салон красоты пришло n девушек. Каждая из них должна посетить парикмахера и косметолога. У каждого она проводит по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
754 000 000 000 000 000 000 в нормализованной форме? 0,000 000 000 000 022 865 в нормализованной форме?
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)