Задать вопрос
2 января, 13:08

4. Составить программу для решения следующей задачи.

(Уровень А) :

Даны катеты прямоугольного треугольника a и b. Найти его площадь S=½*a*b.

(Уровень B) :

Дано целое число. Если оно кратно 3, то удвоить его. В противном случае уменьшить его на величину остатка отделения этого числа на 3. Вывести полученное число.

(Уровень C) :

Найти сумму положительных нечетных чисел, меньших 100.

+1
Ответы (1)
  1. 2 января, 15:20
    0
    Реализация на с++

    Уровень А

    #include

    using namespace std;

    int main () {

    int a, b;

    cin >>a >> b;

    double s = 0.5 * a * b;

    cout << s << endl;

    return 0;

    }

    Уровень B

    #include

    using namespace std;

    int main () {

    int n;

    cin >> n;

    (n%3==0) ? n*2 : n+n%3;

    cout << n << endl;

    return 0;

    }

    Уровень C

    #include

    using namespace std;

    int main () {

    int summa = 0;

    for (int i = 1; i < 100; i+=2) {

    summa + = i;

    }

    cout << summa << endl;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Составить программу для решения следующей задачи. (Уровень А) : Даны катеты прямоугольного треугольника a и b. Найти его площадь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Дано целое число. Если оно кратно 5, то вывести на экран сообщение: "Да" и уменьшить число в 5 раз. В противном случае вывести на экран сообщение "Нет" и при этом число увеличить в 5 раз.
Ответы (1)
Дано число, удвоить его в 3 раза если оно кратно 17. В противном случае уменьшить на 4. Вывести ответ на экран. В pascal abc
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)