Задать вопрос
12 июля, 23:43

Напишите программу для записи четырехзначного числа в обратном порядке.

Например:

2451-->1542

Паскаль.

+4
Ответы (1)
  1. 13 июля, 00:46
    0
    Var n, m: integer;

    begin

    write ('n = ') ; readln (n) ;

    m:=0;

    repeat

    m:=m*10 + (n mod 10) ;

    n:=n div 10;

    until n=0;

    writeln (m) ;

    end.

    n = 2456

    6542
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для записи четырехзначного числа в обратном порядке. Например: 2451-->1542 Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Помогите решить задачу информатика-паскаль (програмирование) Дано целое положительное четырехзначнгое число. Напишите программу, позволяющую определить сумму двух первых цифр заданного четырехзначного числа. Например 1234 - 3
Ответы (1)