Задать вопрос
16 января, 06:24

Язык Паскаль. Дан интервал от - 10 до 10. Найти максимальное и минимальное число.

+2
Ответы (1)
  1. 16 января, 07:12
    0
    Const N=10;

    var i, imax, imin, min, max:integer;

    mas:array[1 ... N]of integer;

    begin

    randomize;

    for i:=1 to N do

    mas[i]:=random (21) - 10;

    for i:=1 to N do

    write (mas[i]:4) ;

    writeln;

    imax:=1;

    max:=mas[1];

    for i:=2 to N do

    if max
    begin

    max:=mas[i];

    imax:=i

    end;

    writeln ('Максимальный элемент=', max) ;

    writeln;

    imin:=1;

    min:=mas[1];

    for i:=2 to N do

    if min>mas[i] then

    begin

    min:=mas[i];

    imin:=i;

    end;

    writeln ('Минимальный элемент=', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Язык Паскаль. Дан интервал от - 10 до 10. Найти максимальное и минимальное число. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Дан одномерный массив из n элементов в интервале [0,50] найти количество элементов попадающих в интервал [0,25] и количество элементов попадающих в интервал[40,50] (через процедуру)
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Напишите программу, которая находит минимальное и максимальное среди чётных положительных чисел, записанных в файле, и выводит результат в другой файл. Учтите, что таких чисел может вообще не быть. (Язык программирования Паскаль)
Ответы (1)