Задать вопрос
12 марта, 19:56

Составить программу. Если число положительное то увеличте его в 2 раза, если число отрицательное то уменьшите его в 2 раза

+4
Ответы (2)
  1. 12 марта, 20:07
    0
    Program task;

    var a:real;

    begin

    write ('Введите число : ') ;

    read (a) ;

    if a>0 then writeln (a*2)

    else writeln (a/2) ;

    end.
  2. 12 марта, 20:58
    0
    А что делать с нулём? : D На паскале получится вроде что-то этого:

    Program: ...

    Var: a; integer;

    Begin

    readln (a) ;

    begin

    If a>0 then

    a: = a*2;

    else a: = a:2;

    end;

    writeln (a) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу. Если число положительное то увеличте его в 2 раза, если число отрицательное то уменьшите его в 2 раза ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран
Ответы (1)
Пусть дано некоторое целое число. Требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное.
Ответы (1)