Задать вопрос
26 мая, 20:35

Найти максимальную и минимальную цифры числа. Верно ли, что данное число заканчивается на них?

Нужна программа в турбо паскаль

+5
Ответы (1)
  1. 26 мая, 20:41
    0
    var a: array[0 ... 9] of integer;

    s: string;

    i, j: integer;

    begin

    for i:=0 to 9 do a[i]:=0;

    write ('число: ') ; readln (s) ;

    for i:=1 to length (s) do inc (a[ord (s[i]) - 48]) ;

    i:=9;

    while a[i]=0 do i:=i-1;

    j:=i;

    i:=0;

    while a[i]=0 do i:=i+1;

    if (chr (j+48) + chr (i+48) = s[length (s) - 1]+s[length (s) ]) or

    (chr (i+48) + chr (j+48) = s[length (s) - 1]+s[length (s) ])

    then writeln ('Да')

    else writeln ('Нет') ;

    end.

    число: 18245390

    Да

    число: 1205483 Нет
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти максимальную и минимальную цифры числа. Верно ли, что данное число заканчивается на них? Нужна программа в турбо паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Что является составляющими языка? а) Синтаксис; б) Семантика; в) Грамматика; г) Морфология. 2. Средой Что есть визуального программирования? а) Турбо Паскаль; б) Турбо в Excel; в) Турбо Дельфи; г) базовые. 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Три фирмы A, B и C решили получить максимальную прибыль по итогам года. Экономист, хорошо знавший организацию работы в этих фирмах, высказал следующие предположения: а) фирма C получит максимальную прибыль, если максимальную прибыль получит фирма B
Ответы (1)
Напишите программу в среде программирования Турбо Паскаль, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3.
Ответы (1)