Задать вопрос
5 декабря, 19:08

Паскаль. Тема множества. Написать программы:

1) в веденной строке удвойте каждое вхождение буквы "а"

2) найти количество всех букв "z" в строке

3) проверить, является ли введённое слово словом-перевертышем, то есть, читается ли оно одинаково справа и слева

+1
Ответы (1)
  1. 5 декабря, 22:53
    0
    Var

    s:string;

    cnt, i, j:integer;

    begin

    Readln (s) ;

    for i: = 1 to length (s) do

    begin

    if s[i] = 'a' then write ('a') ;

    write (s[i]) ;

    if s[i] = 'z' then cnt: = cnt+1;

    end;

    Writeln;

    Writeln ('Кол-во "z" в слове: ', cnt) ;

    for i: = 1 to length (s) do

    if s[i] s[length (s) - i+1] then begin

    Writeln ('Это не палиндром') ;

    halt;

    end;

    Writeln ('Это палиндром') ;

    end.

    Пример:

    abazaba

    aabaazaabaa

    Кол-во "z" в слове: 1

    Это палиндром
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Тема множества. Написать программы: 1) в веденной строке удвойте каждое вхождение буквы "а" 2) найти количество всех букв "z" в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано трёхзначное число. Напишите в паскаль программу, которая определяет: Является ли число "перевёртышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
Дано натуральное число. Выяснить, является ли оно палиндромом ("перевертышем"), т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. Помогите написать на паскале
Ответы (1)
Дано трёхзначное число. выясните, является ли оно палиндромом ("перевёртышем"), т. е. таким числом, которое читается одинаково и справа налево, и слева направо.
Ответы (1)
Составьте программу, которая позволяет определить, является ли введенная строка перевертышем, то есть читается одинаково справа налево и слева направо
Ответы (1)
Дано слово. Проверить является ли оно ''перевертышем'' (перевертышем называется слово, читаемое одинакого как с начала так и с конца),
Ответы (1)