Задать вопрос
22 мая, 22:33

Введите число в десятичной системе исчисления. Определите, чего больше - нулей или единиц в его двоичном представлении?

+5
Ответы (1)
  1. 23 мая, 02:00
    0
    C++:

    #include

    using namespace std;

    int main () {

    int n, z = 0, o = 0;

    cin >> n;

    if (n==0) {

    cout << "nuley";

    return 0;

    }

    while (n>0) {

    if (n%2) o++;

    else z++;

    n / = 2;

    }

    if (o>z) cout << "edinits";

    else if (o==z) cout << "odinakovo";

    else cout << "nuley";

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите число в десятичной системе исчисления. Определите, чего больше - нулей или единиц в его двоичном представлении? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
1. Сколько нулей в двоичном представлении числа 3410 2. Выполнить вычитание в двоичной системе счисления: 100102 - 1112 3. Перевести двоичное число 101112 в десятичную систему счисления 4.
Ответы (1)
1. Найти разность 31 (10) - 16 (10) в восьмибитном представлении. Прямой код, обратный код и дополнительный код. 2. Представить число - 292 (10) в двоичном виде в шестнадцатибитном представлении в формате целого со знаком.
Ответы (1)
1. Запишите число 156 в шестнадцатеричной системе счисления. 2. Запишите число AD16 В десятичной системе счисления. 3. Запишите число 111100000012 в шестнадцатеричной системе счисления. 4. Запишите число 125 В 16 В двоичной системе счисления. 5.
Ответы (1)
Дан массив с1, с2, ..., с15, состоящий из нулей и единиц. Подсчитать количество нулей, количество единиц и количество нулей до первой единицы. Это в паскале
Ответы (1)