Задать вопрос
1 июля, 00:34

Написать программу (в Паскале) поиска элемента массива, равного 50

+1
Ответы (1)
  1. 1 июля, 02:21
    0
    Const n=20; p=50;

    var a:array[1 ... n+1] of integer;

    i:integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (100) ;

    write (a[i]:4) ;

    end;

    writeln;

    a[n+1]:=p;

    i:=1;

    while a[i]p do i:=i+1;

    if i
    else writeln ('Значения ', p,' в массиве нет') ;

    end.

    Пример:

    76 27 15 97 12 14 72 50 51 8 40 47 38 28 30 47 31 4 94 3

    Значение = 50 - это 8 элемент массива
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу (в Паскале) поиска элемента массива, равного 50 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм R: = n; For k: = 1 to n do If X[k]
Ответы (1)