Задать вопрос
12 сентября, 01:16

G. Жилищная проблема муравьев

Население инсектополиса составляет N муравьев. Известно, что в одном муравейнике помещается 1000 муравьев, при том один муравейник на 1000 особей уже построен. Определите, сколько еще нужно построить муравейников, чтобы ни в одном из них не было перенаселения.

Формат входных данных

Целое положительное число муравьев N (1 < N < 109)

Формат выходных данных

Целое число - необходимое количество дополнительных муравейников

Примеры:

входные данные выходные данные

2000

1

2001

2

+4
Ответы (1)
  1. 12 сентября, 02:16
    0
    Var n, k:integer;

    begin

    readln (n) ;

    k: = (n-1) div 1000;

    writeln (k) ;

    end.

    Пример:

    2001

    2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «G. Жилищная проблема муравьев Население инсектополиса составляет N муравьев. Известно, что в одном муравейнике помещается 1000 муравьев, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
В кафе мороженое продают по три шарика и по пять шариков. Можно ли купить ровно k шариков мороженого? Входные данные Вводится число k (целое, положительное) Выходные данные Программа должна вывести слово YES, если при таких условиях можно набрать
Ответы (1)