Задать вопрос
11 июня, 11:32

Найти сумму цифр в Паскале (используя while или repeat)

S=101+103 + ... + 301

Составить программу.

+5
Ответы (1)
  1. 11 июня, 12:55
    0
    (использую repeat)

    var i, S:integer;

    begin

    S:=0; i:=101;

    repeat

    S:=S+i; i:=i+2;

    until i>301;

    Writeln (S) ;

    end.

    (использую While)

    var i, S:integer;

    begin

    S:=0; i:=101;

    while i<=301

    do begin

    S:=S+i; i; =i+2;

    end;

    Writeln (S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму цифр в Паскале (используя while или repeat) S=101+103 + ... + 301 Составить программу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте и последовательно соедините на коорд. плоскости точки, координаты которых приведены в двоичной системе счисления: (101,101) (101,101000) (11001,101000) (11001,101) (10100,101) (10100,11110) (1010,11110) (1010,101) (101,101)
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Определить значение переменной у после выполнения следующих фрагментов программы: a) Var у : real; i : integer; у : = 1; i : = 5; while i> 2 do i: = i - 1; y:=y + 1 * i; b) Var у : real; i : integer; у : = 1; i : = 2; repeat i: = 2 * i;
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)