Задать вопрос
18 августа, 01:14

Проверить 3-ех значеное на честность и на сумму его цифр, если четн, если нет то произведение его цифр

+4
Ответы (2)
  1. 18 августа, 01:42
    0
    Var n:integer;

    begin

    Write ('Введите число=') ; Readln (N) ;

    if odd (n) then begin

    Writeln ('сумма цифр=', ((N mod 10) + ((N div 10) mod 10) + (N div 100)) ;

    end

    else

    Writeln ('произведение цифр', ((N mod 10) * ((N div 10) mod 10) * (N div 100)) ;

    end.
  2. 18 августа, 04:05
    0
    Var a, b, c, s:Integer;

    begin

    Read (s) ;

    a: = s div 100;

    b: = s div 10 mod 10;

    c: = s mod 10;

    if odd (s) then

    WriteLn ('Нечетное. произведение чисел равно '+a*b*c)

    else

    WriteLn ('Четное. Сумма чисел равна ' + (a+b+c)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Проверить 3-ех значеное на честность и на сумму его цифр, если четн, если нет то произведение его цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Найти сумму всех четн. элементов многомерного массива. (через датчик случайных чисел)
Ответы (1)
Написать двойной факториал Pascal. Дано натуральное чилсо N. Вычислить n. 1*3*5 ... n, n - нечетн 2*4*6 ... n, n - четн
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)