Задать вопрос
28 сентября, 23:29

Тема массивы.

Язык - pascal abc.

Нужна программа по принципу работы Вводим 10 элементов массива - выводятся нечетные.

+5
Ответы (1)
  1. 29 сентября, 00:03
    0
    const n=10;

    var a:array [1 ... n] of integer;

    i: integer;

    begin

    randomize;

    writeln ("Массив из 10 элементов:') ;

    for i:=1 to n do

    begin

    a[i]: = random (101) ;

    write (a[i],' ') ;

    end;

    writeln ('Нечетные элементы:') ;

    for i:=1 to n do

    if a[i] mod 20 then

    write (a[i],' ') ;

    end.

    Используем рандом для заполнения массива
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Тема массивы. Язык - pascal abc. Нужна программа по принципу работы Вводим 10 элементов массива - выводятся нечетные. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)
Подпрограммы, Pascal ABC Дано массивы А1 (N1, M1), A2 (N2, M2), A3 (N3, M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов.
Ответы (1)