Задать вопрос
6 ноября, 13:48

Написать программу нахождения числа дней в месяце, если даны: Номер месяца n - целое, также дано число а, равное 1 для високосного года и равное 0 в противном случае.

+4
Ответы (1)
  1. 6 ноября, 16:18
    0
    Var

    a:array[1 ... 12]of integer;

    m, n:integer;

    Begin

    a[1]:=31; a[7]:=31;

    a[2]:=28; a[8]:=31;

    a[3]:=31; a[9]:=30;

    a[4]:=30; a[10]:=31;

    a[5]:=31; a[11]:=30;

    a[6]:=30; a[12]:=31;

    Write ('Введите номер месяца - > ') ;

    Readln (m) ;

    Write ('Год високосный (1 - да || 0 - нет) ?') ;

    Readln (n) ;

    if (m = 2) then Writeln (a[m] + n) else

    Writeln (a[m]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу нахождения числа дней в месяце, если даны: Номер месяца n - целое, также дано число а, равное 1 для високосного года и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать алгоритм нахождения числа дней в месяце, если даны: Номер месяца n - целое число а, равное 1 для високосного года и равное 0 в противном случае.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)
Составить программу, которая по номеру месяца, введенного с клавиатуры, выводит количество дней в нем. В программе учесть количество дней в феврале для високосного и не високосного годов
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)