Задать вопрос
25 мая, 09:38

Напишите программу, которая генерирует массив из случайных чисел от 20 до 85 в количестве не более 30 чисел. После этого необходимо посчитать количество чисел, больших введенного вами с клавиатуры.

Hellp решает игоговую оценку

+2
Ответы (1)
  1. 25 мая, 12:14
    0
    Program n1;

    const n=15;

    var a: array[1 ... n] of integer;

    i, b, k: integer;

    begin

    randomize;

    write ('массив: ') ;

    for i:=1 to n do begin

    a[i]:=random (66) + 20;

    write (a[i],' ') ;

    end;

    writeln;

    write ('введите число: ') ;

    readln (b) ;

    k:=0;

    for i:=1 to n do if a[i]>b then k:=k+1;

    write ('k=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая генерирует массив из случайных чисел от 20 до 85 в количестве не более 30 чисел. После этого необходимо ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio)
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)