Задать вопрос
8 сентября, 16:03

10. Напишите программу: "Склавиатуры вводится строка из двух слов. Вывести н экран: a) первую и последнюю буквы второго слова; б) количество букв второго слова; в) количество глассных (a) в строке. все это должно быть в одной программе

+2
Ответы (1)
  1. 8 сентября, 18:38
    0
    Var s: string;

    n, k: integer;

    begin

    write ('строка: ') ; readln (s) ;

    n:=pos (' ', s) ;

    if n>0 then

    begin

    writeln ('первая буква второго слова: ', s[n+1]) ;

    writeln ('последняя буква: ', s[length (s) ]) ;

    writeln ('количество букв: ', length (s) - n) ;

    k:=0;

    for n:=1 to length (s) do

    if s[n]='a' then k:=k+1;

    if k>0 then writeln ('количество букв a: ', k)

    else writeln ('в строке нет буквы a') ;

    end

    else writeln ('в строке одно слово') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «10. Напишите программу: "Склавиатуры вводится строка из двух слов. Вывести н экран: a) первую и последнюю буквы второго слова; б) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)