Задать вопрос
2 ноября, 10:49

Написать программу, которая находит целую часть и остаток от деления целого числа на 2

+4
Ответы (1)
  1. 2 ноября, 12:51
    0
    Var

    a, b: integer;

    begin

    read (a) ;

    b:=a mod 2;

    a: = (a-b) div 2;

    write ('Остаток от деления: ', b,' Целая часть: ', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит целую часть и остаток от деления целого числа на 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Оператор mod (a, b) - находит остаток от деления целого числа a на целое число b, например: mod (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа a на целое число b, например: div (25,4) = 6.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Оператор mob (a, b) - находит остаток отделения целого числа а на целое число b, например:mob (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа а на целое число b, например:div (25,4) = 6.
Ответы (1)
Оператор mod (a, b) - находится остаток от деления целого число b, напримет: mod (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа а на целое число b, например: div (25,4) = 6.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)