Задать вопрос
12 января, 15:01

В однородном массиве вещественных чисел найти сумму элементов, предшествующих первому положительному элементу, и количество таких элементов

+2
Ответы (1)
  1. 12 января, 16:46
    0
    Program Ok;

    var A:array[1 ... 10] of real;

    sum:real; i, n:integer;

    begin

    randomize;

    sum:=0;

    for i:=1 to 10 do

    begin

    read (A[i]) ;

    end;

    for i:=10 downto 1 do

    begin

    if (A[i]>0) then

    n:=i;

    end;

    for i:=1 to 9 do

    begin

    if (A[n] = A[i+1]) then

    sum:=sum+1;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В однородном массиве вещественных чисел найти сумму элементов, предшествующих первому положительному элементу, и количество таких элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
На языке Си, не си + + Дан массив Х (324). Найти сумму элементов массива, предшествующих первому отрицательному элементу. Если среди элементов массива нет отрицательных, то просуммировать все элементы.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)