Задать вопрос
26 ноября, 17:56

Составить программу, которая заполняет моссив A (n) в порядке 1 2 3 1 2 3

+1
Ответы (1)
  1. 26 ноября, 19:10
    0
    Program massiv123;

    const n=30;

    Type massiv=array[1 ... n] of integer;

    var i:integer; a:massiv;

    begin

    for i:=1 to n do

    if i mod 3=0 then a[i]:=3

    else a[i]:=1;

    for i:=1 to n do

    if a[i]=3 then a[i-1]:=2;

    write ('Массив: ') ;

    for i:=1 to n-1 do

    write (a[i],',') ;

    write (a[n],'; ') ;

    end.

    Если надо изменить кол-во цифр, то изменяйте в const n=кол-во;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая заполняет моссив A (n) в порядке 1 2 3 1 2 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Компьютер вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус Д заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)
Компьютерный вирус А заполняет 1 Гб памяти за один месяц, вирус В заполняет 1 Гб за два месяца, вирус С заполняет 1 Гб за три месяца, вирус D заполняет 1 гб за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)
Компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус D заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса.
Ответы (1)