Задать вопрос
17 июля, 17:48

Задана последовательность из 10 целых чисел. Для каждого элемента начиная со второго найти разницу с предыдущим элементом (ai - ai - 1)

+1
Ответы (2)
  1. 17 июля, 20:29
    0
    Ответ пишу в комментариях, использовал массив, так проще). На входе вводишь 10 чисел на выходе 5 разниц.

    Если сделал что-то не так, пиши поправлю!
  2. 17 июля, 21:07
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (51) ;

    write (a[i]:4) ;

    end;

    writeln;

    writeln ('Искомые разности:') ;

    for i:=2 to n do write (a[i]-a[i-1]:4) ;

    writeln;

    end.

    Пример:

    3 43 32 33 18 29 21 48 33 28

    Искомые разности:

    40 - 11 1 - 15 11 - 8 27 - 15 - 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задана последовательность из 10 целых чисел. Для каждого элемента начиная со второго найти разницу с предыдущим элементом (ai - ai - 1) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Дана последовательность целых чисел. Прищнак окончания ввода - число 0 (элементом последовательности не считается). В последовательности как минимум одно число. Написать программу, определяющую, является ли последовательность чисел возрастающей.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)