Задать вопрос
15 февраля, 00:39

Ввести с клавиатуры 4 числа, если сумма 1-ого и 2-ого чисел больше 20, то уменьшить эту сумму на 10. иначе увеличить на 10, если 2 число не отрицательное (> или = 0), то уменьшить все числа на единицу. иначе вычислить среднее арифметическое всех чисел (паскаль)

+2
Ответы (1)
  1. 15 февраля, 02:43
    0
    Ответ в комментарии, для лучшей читаемости кода.

    program chicla; var a, b, c, d, f, sum:integer; sr:real; begin Writeln ('Ââåäèòå ïåðâîå : èñëî') ; readln (a) ; Writeln ('Ââåäèòå âòîðîå : èñëî') ; readln (b) ; Writeln ('Ââåäèòå òðåòüå : èñëî') ; readln (c) ; Writeln ('Ââåäèòå : åòâåðòîå : èñëî') ; readln (d) ; f:=a+b; if f>20 then begin f:=f-10; writeln (f) ; end else begin f:=f+10; writeln (f) end; if b>=0 then begin a:=a-1; b:=b-1; c:=c-1; d:=d-1; writeln ('1 : èñëî ïîñëå óìåíüøåíèÿ íà åäèíèöó = ', a) ; writeln ('2 : èñëî ïîñëå óìåíüøåíèÿ íà åäèíèöó = ', b) ; writeln ('3 : èñëî ïîñëå óìåíüøåíèÿ íà åäèíèöó = ', c) ; writeln ('4 : èñëî ïîñëå óìåíüøåíèÿ íà åäèíèöó = ', d) ; end else begin sr: = (a+b+c+d) / 4; writeln ('Ñðåäíåå àðèôìåòè:åñêîå = ', sr) ; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры 4 числа, если сумма 1-ого и 2-ого чисел больше 20, то уменьшить эту сумму на 10. иначе увеличить на 10, если 2 число не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Переведите на язык программирования: а) ввести А и С увеличить А в 10 раз уменьшить С в 20 раз напечатать модуль разности А и С б) ввести А и С если А>С, то увеличить А в 5 раз иначе уменьшить С в 2 раза напечатать значения А и С конец в) ввести
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Помогите с ИКТ, 9 класс, Паскаль! #1 Ввести число, если оно отрицательное, найти его квадрат и вывести результат, иначе вывести на экран число положительное. #2 Ввести значение Х, вычислить значение Z, где Z=Х^2 (Х во второй степени) при х >0.
Ответы (1)
Ввести c клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива. Пример: Введите пять чисел: 4 15 3 10 14 среднее арифметическое 9.200
Ответы (1)