Задать вопрос
6 августа, 04:09

Сложное задание по информатике:

Нужно написать программу на паскале, не используя if, then, else, с таким результатом:

Введите число

если число четное, то вывести 10;

если нечетное, то вывести - 10

+1
Ответы (2)
  1. 6 августа, 07:13
    0
    Var a:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    writeln (-20 * (abs (a) mod 2) + 10) ;

    end.

    Пример:

    a = 28

    10
  2. 6 августа, 07:27
    0
    Var

    n: integer;

    res: boolean;

    begin

    readln (n) ;

    res:=odd (n) ;

    case res of

    true: writeln ('-10') ;

    false: writeln ('10') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сложное задание по информатике: Нужно написать программу на паскале, не используя if, then, else, с таким результатом: Введите число если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике