Задать вопрос
8 июня, 17:31

Посчитать сумму и произведение тех элементов массива, которые являются нечётными и меньше 30. (Паскаль)

+3
Ответы (1)
  1. 8 июня, 18:49
    0
    Var

    a: array[1 ... 10] of integer;

    i, s, p: integer;

    begin

    for i:=1 to 10 do

    readln (a[i]) ;

    s:=0; p:=1;

    for i:=1 to 10 do

    if (a[i] mod 2 > 0) and (a[i] < 30) then

    begin

    s:=s+a[i];

    p:=p*a[i];

    end;

    writeln (s) ;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Посчитать сумму и произведение тех элементов массива, которые являются нечётными и меньше 30. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)