Задать вопрос
16 июля, 06:23

Выполнить округление натурального числа N с точность до десятков (стандартные функции округления и функции работы со строками не использовать)

+3
Ответы (1)
  1. 16 июля, 08:23
    0
    Var

    n: integer;

    a, b: integer;

    begin

    Readln (n) ;

    a: = n mod 10;

    b:=n div 10;

    if a>4 then inc (b) ;

    b:=b*10;

    Writeln (b)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Выполнить округление натурального числа N с точность до десятков (стандартные функции округления и функции работы со строками не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите имя блока, который образуется пересечением: 1) столбцов C, D, E со строками 5, 6, 7, 8; 2) столбцов F, G со строками 1, 2, 3; 3) столбцов B, C, D, E со строками 9,10.
Ответы (2)
Написать программу округление числа с любой точность (где точность и число вводятся с клавиатуры)
Ответы (1)
Что такое стандартные функции и стандартные процедуры? Дайте определение
Ответы (1)
Выключить монитор Ход работы: Отсоединить монитор от компьютера Ход работы: Отсоединить мышь и клавиатуру Ход работы: Отсоединить все остальные имеющиеся внешние устройства кабеля Ход работы: Подключить к компьютеру монитор Ход работы: Подключить к
Ответы (1)
Учитель проверяет работы письменного экзамена. Изначально на его столе нет ни одной работы. Иногда приносят стопку работ с подряд идущими номерами, при этом номера работ увеличиваются от низа стопки к ее верху.
Ответы (1)