Задать вопрос
10 февраля, 11:24

Даны значения а b c.

Составить программу вычислений значения наименьшего отклонения каждого из трёх чисел от их среднего арифметического значения и печати его значения и имени соответствующей переменной.

+3
Ответы (1)
  1. 10 февраля, 13:55
    0
    Var a, b, c, q:real;

    begin

    read (a, b, c) ;

    q: = (a+b+c) / 3;

    writeln ('a: ', abs (a-q)) ;

    writeln ('b: ', abs (b-q)) ;

    writeln ('c: ', abs (c-q)) ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны значения а b c. Составить программу вычислений значения наименьшего отклонения каждого из трёх чисел от их среднего арифметического ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задан одномерный массив Z (N) (N
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Помогите, кто знает хорошо visual basic Нужно прописать в программе Функция должна возвращать Величину среднего абсолютного отклонения Отношение среднего квадратического отклонения к среднему абсолютному отклонению Среднее арифметическое из средних
Ответы (1)
Запишите оператор для: а) вычисления среднего арифметического переменных x1 и x2, б) уменьшения на единицу значения переменной k в) увеличение на еденицу значения переменной i г) вычисления стоимости покупки, состоящей из нескольких тетрадей,
Ответы (1)
Опишите процесс выполнения операторов присваивания. a:=3; b:=4; a:=a+b Запишите операторы для: Вычисления среднего арифметического переменных х1 и х2. Уменьшения на единицу значения переменной К. Увеличения на единицу значения переменной i.
Ответы (1)