Задать вопрос
18 октября, 16:41

Даны два целых числа от 1 до 1 000 000 000. Найти сумму этих чисел. Входные данные: два целых числа. Выходные данные: целое число. На Паскале

+4
Ответы (1)
  1. 18 октября, 19:32
    0
    Точная задача по Техническому Заданию:

    var x, y:integer;

    begin

    writeln ('введите два числа') ;

    readln (x) ;

    readln (y) ;

    if (x<1000000001) and (y0) and (y>0)

    then writeln ('сумма чисел = ', x+y)

    else writeln ('диапазон чисел неверный') ;

    end.

    Если вдруг вам поверит учитель, можете перевыполнить поставленную задачу:

    var x, y:integer;

    s:string;

    begin

    randomize;

    writeln ('взять ли числа случайными? Ответ да или нет') ;

    readln (s) ;

    if (s='да') or (s='Да') or (s='ДА') or (s='дА') then begin

    x:=random (1000000000) ;

    y:=random (1000000000) ;

    writeln ('сумма чисел = ', x+y) ;

    writeln ('произведение чисел = ', x*y) ;

    end

    else begin

    writeln ('введите два числа') ;

    readln (x) ;

    readln (y) ;

    writeln ('сумма чисел = ', x+y) ;

    writeln ('произведение чисел = ', x*y) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два целых числа от 1 до 1 000 000 000. Найти сумму этих чисел. Входные данные: два целых числа. Выходные данные: целое число. На ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Напишите программу, вычисляющую 2^N. Входные данные Вводится целое неотрицательное число N, которое не превосходит 30. Выходные данные Выведите число 2^N.
Ответы (1)