Задать вопрос
1 декабря, 12:13

На одномерные массивы: В последовательности вещественных чисел. Определить образуют ли они убывающую последовательность. Если да, найти произведение последнего и центрального элементов. Написать Код Pascal

+3
Ответы (1)
  1. 1 декабря, 15:25
    0
    В программе генерируются только убывающие последовательности (a[i]:=-i+random () + 20;). Можно при желании массив вводить с клавиатуры.

    const n=15;

    var a:array[1 ... n] of real;

    i:integer; b:boolean;

    begin

    Randomize;

    for i:=1 to n do begin

    a[i]:=-i+random () + 20;

    write (a[i]:5:2,' ') ;

    end;

    writeln;

    b:=true;

    for i:=1 to n-1 do

    if a[i+1]>=a[i] then b:=false;

    if b

    then

    begin

    writeln ('Последовательность убывающая') ;

    writeln ('p = ', a[n]*a[n div 2+1]:5:2) ;

    end

    else writeln ('Последовательность не убывающая')

    end.

    Пример:

    19.02 18.28 17.91 16.67 15.03 14.68 13.10 12.86 11.91 10.19 9.66 8.35 7.37 6.55 5.20

    Последовательность убывающая

    p = 66.86
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На одномерные массивы: В последовательности вещественных чисел. Определить образуют ли они убывающую последовательность. Если да, найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Подпрограммы, Pascal ABC Дано массивы А1 (N1, M1), A2 (N2, M2), A3 (N3, M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов.
Ответы (1)
Дано массивы А1 (N1, M1), A2 (N2, M2), A3 (N3, M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Дан вещественный массив, состоящий из 7 элементов. Найти произведение этих элементов (одномерные массивы, 10 класс).
Ответы (1)