Задать вопрос
9 ноября, 07:40

Даны 3 числа (а, в, с). Составьте программу, которая меняет местами max и min элементы. Не массив.

+4
Ответы (2)
  1. 9 ноября, 10:57
    0
    Var

    a, b, c:integer;

    max, min:integer;

    begin

    readln (a, b, c) ;

    if ((a>=b) and (a>=c) and (b=a) and (b>=c) and (a<=c)) then swap (a, b)

    else

    if ((a>=b) and (a>=c) and (c=b) and (c>=a) and (a<=b)) then swap (a, c)

    else

    if ((b>=a) and (b>=c) and (c=b) and (c>=a) and (b<=a)) then swap (b, c) ; writeln (a,' ', b,' ', c) ;

    end.
  2. 9 ноября, 11:19
    0
    Var a, b, c, d:integer;

    begin

    writeln ('a, b, c:') ;

    readln (a, b, c) ;

    if (a>b) and (ac) and (a
    then begin d:=b; b:=c; c:=d; end

    else if (b>a) and (bc) and (b
    then begin d:=a; a:=c; c:=d; end

    else begin d:=a; a:=b; b:=d; end;

    writeln ('a = ', a,' b = ', b,' c = ', c) ;

    end.

    Пример:

    a, b, c:

    8 5 2

    a = 2 b = 5 c = 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 3 числа (а, в, с). Составьте программу, которая меняет местами max и min элементы. Не массив. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы