Задать вопрос
2 января, 03:10

Найти количество элементов массива, значения которых кратны 3 и 5

+4
Ответы (1)
  1. 2 января, 05:28
    0
    Var

    a:array[1 ... 10] of integer;

    i, k:integer;

    begin

    for i:=1 to 10 do begin

    write (i,'-й элемент: ') ;

    readln (a[i]) ;

    end;

    k:=0

    for i:=1 to 10 do

    if a[i] mod 3 = 0 and a[i] mod 5 = 0 then

    k:=k+1; {если кратно и 3, и 5 одновременно, то and. Если или 3, или 5, то or}

    writeln (k,' элементов') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество элементов массива, значения которых кратны 3 и 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)