Задать вопрос
26 декабря, 13:00

Написать программу Pascal, которая выводила бы число в обратной последовательности

+1
Ответы (1)
  1. 26 декабря, 14:22
    0
    Procedure Chisla (n : Integer) ;

    var a : Integer;

    begin

    if (n < 1) then

    WriteLn

    else

    begin

    Read (a) ;

    if (Abs (a) < 1000) then

    begin

    Chisla (n-1) ;

    Write (a,' ') ;

    end

    else

    Chisla (n) ;

    end; end; function ReadN () : Integer;

    var

    n : Integer; begin

    Write ('n=') ;

    ReadLn (n) ;

    if Not (n in [0 ... 1000]) then

    n : = ReadN () ;

    ReadN : = n; end; var

    n : Integer; begin

    n : = ReadN () ;

    WriteLn ('Введите ', n, ' целых чисел через пробел и нажмите Enter') ;

    Chisla (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу Pascal, которая выводила бы число в обратной последовательности ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1. приведите по 2-3 примера кибернетических систем: а) без обратной связи; б) с обратной связью 2. какую структуру может иметь управляющий алгоритм: а) без обратной связи; б) при наличии обратной связи?
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)