Задать вопрос
10 мая, 14:57

Составить программу, которая заполняет массив b [1 ... 10] случайными целыми числами в диапазоне от 1 до 15 и находит количество с нечётными значениями

+1
Ответы (1)
  1. 10 мая, 16:09
    0
    Var mass:array[1 ... 10] of integer;

    i, g, s:integer;

    begin

    randomize;

    writeln ('введите максимальное случайное число') ;

    readln (i) ;

    for g:=1 to 10 do

    begin

    mass[g]:=random (i) + 1;

    if (mass[g] mod 2) = 0 then s:=s+1;

    writeln (mass[g]) ;

    end;

    writeln ('количество четных в массиве = '+s) ;

    writeln ('количество нечетных в массиве = ' + (10-s)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая заполняет массив b [1 ... 10] случайными целыми числами в диапазоне от 1 до 15 и находит количество с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
Составьте программу которая заполняет массив b1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количеством элементов с четными значениями помогите хоть каким решением
Ответы (1)