Задать вопрос
22 октября, 08:55

Задание: Вы ввели трехзначное число. Составьте программу, определяющую, есть ли в этом числе, четные цифры.

Вопрос: в какой программе решается данная задача и каким образом?

+2
Ответы (2)
  1. 22 октября, 09:11
    0
    Лучше всего сделать в pascal.

    Попробуй этот код:

    var n: integer; boo: boolean; begin write ('Введите число: ') ; readln (n) ; boo:=odd (n) ; case boo of true: writeln ('Нечетное') ; false: writeln ('Четное') ; end; readln; end.
  2. 22 октября, 10:58
    0
    Program OddNumeric;

    var

    n, i: integer;

    a: array [1 ... 3] of byte;

    b: boolean;

    begin

    Write ('Введите трехзначное число: ') ;

    Readln (n) ;

    a[1]:=n div 100; {1 цифра сотен}

    a[2]: = (n div 10) mod 10; {2 цифра десятков}

    a[3]:=n mod 10; {3 цифра количество единиц}

    b:=false;

    for i:=1 to 3 do

    begin

    if (a[i] mod 2) = 0 then

    b:=true;

    end;

    if b then

    Writeln ('В этом числе есть четные цифры')

    else

    Writeln ('В этом числе нет четных цифр') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание: Вы ввели трехзначное число. Составьте программу, определяющую, есть ли в этом числе, четные цифры. Вопрос: в какой программе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вы ввели трехзначное число. Затем ввели любую цифру. Составьте программу, определяющую, есть ли в этом числе данная цифра.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)