Задать вопрос
25 августа, 21:43

Составьте программу которая содержит функцию нахождения количества разрядов заданного числа не превосходящего 1000000000

+1
Ответы (1)
  1. 26 августа, 00:45
    0
    Function kr (n:longint) : integer;

    var

    s:string;

    begin

    Str (Abs (n), s) ;

    kr:=Length (s)

    end;

    var

    k:longint;

    begin

    Write ('Введите целое число: ') ; Read (k) ;

    Writeln ('В этом числе количество разрядов равно ', kr (k))

    end.

    Пример работы программы

    Введите целое число: 1234567

    В этом числе количество разрядов равно 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая содержит функцию нахождения количества разрядов заданного числа не превосходящего 1000000000 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо (если количество разрядов задано положительное) или влево (если количество разрядов задано отрицательное).
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
КАК здесь определяется сумма разрядов? Произведём обработку каждого слова принятого сообщения. Первое слово: 1101001, сумма его разрядов 4 - чётная, слово не изменяется. Второе слово: 0001001, сумма его разрядов 2 - чётная, слово не изменяется.
Ответы (2)
Автомат получает на вход два трехзначных числа. По этим числам строится новое число по следующим правилам. Вычисляются три числа - сумма старших разрядов заданных трехзначных чисел, сумма средних разрядов этих чисел, сумма младших разрядов.
Ответы (1)