Задать вопрос
6 сентября, 13:00

Напишите программу, определяющую количество и сумму элементов массива целых случайных чисел, больших 50 и меньших 60.

+5
Ответы (1)
  1. 6 сентября, 14:33
    0
    Const

    nn=100;

    var

    n, i, k, s:integer;

    a:array[1 ... nn] of integer;

    begin

    Write ('Количество элементов в массиве: ') ; Read (n) ;

    Randomize;

    Writeln ('Сформированный массив') ;

    k:=0; s:=0;

    for i:=1 to n do begin

    a[i]:=Random (100) ;

    Write (a[i],' ') ;

    if (a[i] in [51 ... 59]) then begin s:=s+a[i]; Inc (k) end

    end;

    Writeln;

    Writeln ('На интервале [51 ... 59] найдено элементов - ', k) ;

    Writeln ('Их сумма равна ', s)

    end.

    Пример выполнения программы

    Количество элементов в массиве: 20

    Сформированный массив

    26 65 64 80 46 0 54 38 63 14 63 81 40 42 17 16 23 88 61 54

    На интервале [51 ... 59] найдено элементов - 2

    Их сумма равна 108

    Замечание

    Если конструкция a[i] in [51 ... 59] кажется незнакомой, её можно заменить на более длинную и менее эффективную (a[i]>50) and (a[i]<60)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, определяющую количество и сумму элементов массива целых случайных чисел, больших 50 и меньших 60. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)