Задать вопрос
3 декабря, 03:17

Написать программу (Delphi или Pascal) для вычисления минимального произведения отрицательных подряд идущих элементов одномерного массива.

+3
Ответы (1)
  1. 3 декабря, 03:46
    0
    Const n=10; var A: array [1 ... n] of integer; p, min, i, : integer; beginrandomize; for i: = 1 to n dobeginA[i]: = - 100 + random (200) ; write (A[i]: 5) ; end; writeln; min:=100000000; p:=1; for i:=1 to n doif A[i] < 0 then p:=p*A[i] else Begin if p< min then min:=p; p:=1; End; if pКомментировать
  2. Жалоба
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу (Delphi или Pascal) для вычисления минимального произведения отрицательных подряд идущих элементов одномерного массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите с ответом
Какая масса алюминия прореагирует с хлоридной кислотой, если при этом выделится пять моль водорода?
Нет ответа
Уравнения реакций взаимодействия пропена с водородом, бромом, бромоводородом
Нет ответа
Запишите уравнения реакций дегидрирования пропана и бутана и попробуйте дать названия продуктам по аналогии с этиленом.
Нет ответа
Образуйте краткую форму единственного (всех родов) и множественного числа от данный прилагательных. Бесчисленный. благословенный. Болезненный. Естественный. Малодейственный. Малосущественный. Малоурожайный. Многочисленный. Мужественный. Нравственный
Нет ответа
Выполнить морфологический разбор прилагательных: осенний, сухих
Нет ответа