Задать вопрос
2 сентября, 01:35

Определите количество чётных положительных элементов массива А

+2
Ответы (1)
  1. 2 сентября, 04:01
    0
    Паскаль

    var A:array[1 ... 100] of integer;

    n, i, k:integer;

    begin

    write ('Введите количество элементов массива: ') ; readln (n) ;

    writeln ('Введите элементы массива: ') ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    if (a[i]>0) and (not odd (a[i])) then inc (k) ;

    writeln ('кол-во четных положительных элементов = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите количество чётных положительных элементов массива А ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)