Задать вопрос
25 февраля, 08:27

Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). Нужна программа на паскале.

Входные данные: 1

Выходные данные: 1

+5
Ответы (1)
  1. 25 февраля, 09:06
    0
    Var

    n, s, p, d:longint;

    begin

    Write ('Введите двоичное число: ') ; Read (n) ;

    s:=0; p:=1;

    repeat

    d:=n mod 10;

    s:=s+d*p;

    p:=p*2;

    n:=n div 10

    until n=0;

    Writeln ('В десятичной системе это число равно ', s)

    end.

    Пример

    Введите двоичное число: 1101011

    В десятичной системе это число равно 107
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). Нужна программа на паскале. Входные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
1. Переведите число 001100 из двоичной сс в десятичную 2. Сложить два числа в двоичной СС 001010 и 010001. 3. Перевести число 150 из десятичной СС в двоичную. 4. Перевести число 0010 из двоичной СС в десятичную. 5.
Ответы (2)