Задать вопрос
22 декабря, 02:43

Составить массив из 10 целых случайных чисел на промежутке от - 30 до 30. Вывести массив. Найти количество чётных элементов и вывести их номера

+3
Ответы (1)
  1. 22 декабря, 06:07
    0
    Var

    i, count:integer;

    mas: array [1 ... 10] of integer;

    begin

    randomize;

    for i:=1 to 10 do begin

    mas[i]:=random (-30,30) ;

    write (mas[i], ' ') ;

    end;

    writeln ('') ;

    writeln ('Номера четных элементов') ;

    count:=0;

    for i:=1 to 10 do begin

    if mas[i] mod 2 = 0 then begin

    write (i,' ') ;

    count:=count+1;

    end;

    end;

    writeln ('') ;

    writeln ('Количество четных элементов = ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить массив из 10 целых случайных чисел на промежутке от - 30 до 30. Вывести массив. Найти количество чётных элементов и вывести их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)