Задать вопрос
12 января, 09:35

Подсчитайте произведение отрицательных элементов массива, заполненного заранее известными значениями - 24, 53, 76, - 2, - 43

+2
Ответы (1)
  1. 12 января, 10:37
    0
    var a:array[1 ... 5] of integer = (-24,53,76,-2,-43) ;

    i, p:integer;

    begin

    p:=1;

    for i:=1 to 5 do

    if a[i]<0 then p:=p*a[i];

    writeln ('p = ', p) ;

    end.

    Результат:

    p = - 2064
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитайте произведение отрицательных элементов массива, заполненного заранее известными значениями - 24, 53, 76, - 2, - 43 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)