Задать вопрос
14 февраля, 12:50

Дан вектор В[1:15].

а) найти сумму четных элементов в четных ячейках

б) переставить местами мах и первый элемент вектора

в) отсортировать вектор по убыванию

г) получить сумму элементов между последним и max элементами вектора.

PascalABC

+5
Ответы (1)
  1. 14 февраля, 13:44
    0
    Там где символы не понятные это разделители задач, 3 из 4

    program task;

    const n=15;

    var a:array[1 ... n] of integer;

    i, s, j, first, max: integer;

    begin

    óñëîâèå À

    begin

    a[i]:=0+random (15) ;

    write (a[i]:4) ;

    if (i mod 2=0) then

    s:=s + a[i];

    end;

    çàäà:à Á

    begin

    a[i]:=0+random (15) ;

    write (a[i]:4) ;

    end;

    writeln () ;

    max:=1;

    for i:=1 to n do

    if a[i]>a[max] then max:=i;

    first:=a[1];

    a[1]:=a[max];

    a[max]:=first;

    writeln ('Âåêòîð:') ;

    for i:=1 to n do

    çà:à Â

    for i: = 1 to 15 do begin

    a[i]: = random (20) ;

    write (a[i],' ') ;

    if a[i] > 0 then

    end;

    writeln;

    writeln;

    for i: = 1 to 14 do

    for j: = i+1 to 15 do

    if a[i] < a[j] then begin

    max: = a[i];

    a[i]: = a[j];

    a[j]: = max;

    end;

    for i: = 1 to 15 do begin

    write (a[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан вектор В[1:15]. а) найти сумму четных элементов в четных ячейках б) переставить местами мах и первый элемент вектора в) отсортировать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
задание с кратким ответом. Записать формулы: а) сложения чисел, хранящихся в ячейках А1 и В1 б) вычитания чисел, хранящихся в ячейках А3 и В5 в) умножения чисел, хранящихся в ячейках С1 и С2 г) делания чисел, хранящихся в ячейках А10 и В10
Ответы (1)
Паскаль Как написать программу, которая уменьшала бы ВСЕ максимальные элементы в два раза? Так? max:=a[1,1]; if a[i, j] > max then max: = a[i, j]; end; max: = max div 2;
Ответы (2)
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
Что будет написано после выполнения алгоритма? алг буква_1 нач опустить перо сместиться на вектор (0, 4) сместиться на вектор (1, - 2) сместиться на вектор (1, 2) сместиться на вектор (0, - 4) поднять перо сместиться на вектор (1, 0) кон алг буква_2
Ответы (1)
Помогите переделать код на C# Дан одномерный массив из n элементов. Требуется найти максимальный элемент и отклонение от максимального для каждого из элементов. (Ввод элементов с клавиатуры) var a:array[1 ...
Ответы (1)