Задать вопрос
5 июля, 20:47

Создать двумерный массив из 5 строк, 3 столбцов. Вывести на экран числа кратные 8 оканчивающиеся на 4. Pascal ABC

+3
Ответы (1)
  1. 6 июля, 00:24
    +1
    Const

    m=5;

    n=3;

    var

    i, j, k:integer;

    a:array[1 ... m, 1 ... n] of integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    k:=0;

    for i:=1 to m do begin

    for j:=1 to n do begin

    a[i, j]:=Random (999) + 1;

    Write (a[i, j]:4) ;

    if (a[i, j] mod 8=0) and (a[i, j] mod 10=4) then Inc (k) ;

    end;

    Writeln

    end;

    if k>0 then begin

    Writeln ('Искомые элементы') ;

    for i:=1 to m do

    for j:=1 to n do

    if (a[i, j] mod 8=0) and (a[i, j] mod 4=10) then Write (a[i, j],' ')

    end

    else

    Writeln ('Нет элементов, кратных 8 и оканчивающихся на 4')

    end.

    Пример работы программы

    Исходный массив

    424 672 826

    546 587 413

    507 211 884

    252 781 518

    750 656 359

    Искомые элементы

    424
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать двумерный массив из 5 строк, 3 столбцов. Вывести на экран числа кратные 8 оканчивающиеся на 4. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Написать программу, которая объявит двумерный массив, в котором 15 строк и 12 столбцов. Заполнить массив случайными числами от 1 до 40. Вывести на экран.
Ответы (1)
В pascal. 1) Заполните массив случайными числами из интервала [-50; 50), вывести на экран, посчитать сумму отрицательных элементов. 2) Ввести одномерный массив, вывести его на экран, найти максимальный элемент и его порядковый номер.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)